Speed Dreams

This commit is contained in:
Adrien Bourmault 2023-12-13 12:06:43 +01:00
parent 726e7b5867
commit 9800ba2db6
No known key found for this signature in database
GPG Key ID: 2974E1D5F25DFCC8
2 changed files with 122 additions and 9 deletions

View File

@ -0,0 +1,102 @@
diff --git packaging/CMakeLists.txt packaging/CMakeLists.txt
index 4d796e18f..893a1a508 100644
--- packaging/CMakeLists.txt
+++ packaging/CMakeLists.txt
@@ -118,3 +118,5 @@ IF(NOT MSVC)
WORKING_DIRECTORY ${CMAKE_SOURCE_DIR}
COMMENT "Create tar source archives")
ENDIF(NOT MSVC)
+
+ADD_SUBDIRECTORY(desktop)
diff --git packaging/desktop/CMakeLists.txt packaging/desktop/CMakeLists.txt
new file mode 100644
index 000000000..b68d70ab5
--- /dev/null
+++ packaging/desktop/CMakeLists.txt
@@ -0,0 +1,21 @@
+# Copyright (C) 2022 Matthew Fennell <matthew.robert.fennell@gmail.com>
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+IF(UNIX AND NOT APPLE)
+ INSTALL(FILES net.speed_dreams.desktop
+ DESTINATION ${CMAKE_INSTALL_PREFIX}/share/applications)
+ INSTALL(FILES ${CMAKE_SOURCE_DIR}/data/data/icons/icon.svg
+ DESTINATION ${CMAKE_INSTALL_PREFIX}/share/icons/hicolor/scalable/apps
+ RENAME speed-dreams-2.svg)
+ENDIF(UNIX AND NOT APPLE)
diff --git packaging/desktop/net.speed_dreams.desktop packaging/desktop/net.speed_dreams.desktop
new file mode 100644
index 000000000..de1dadef0
--- /dev/null
+++ packaging/desktop/net.speed_dreams.desktop
@@ -0,0 +1,59 @@
+# Copyright (C) 2022 Hao Liang
+# Copyright (C) 2022 Matthew Fennell <matthew.robert.fennell@gmail.com>
+# Copyright (C) 2022 Zewei Jin
+# Copyright (C) 2022 franzopow
+# Copyright (C) 2022 leillo1975
+# Copyright (C) 2022 madbad82
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+[Desktop Entry]
+Type=Application
+Name=Speed Dreams
+Icon=speed-dreams-2
+Exec=speed-dreams-2
+Terminal=false
+Categories=Game;SportsGame;
+Comment=Motorsport Simulator featuring high-quality 3D graphics and an accurate physics engine
+Comment[ca]=Simulador de deports de motor amb gràfics 3D d'alta calitat i un motor de física precís
+Comment[ca_ES@valencia]=Simulador de deports de motor amb gràfics 3D d'alta calitat i un motor de física precís
+Comment[de]=Motorsport Simulator mit hochwertigen 3D Grafiken und präziser Physik-Engine
+Comment[es]=Simulador de deportes de motor con gráficos 3D de alta calidad y un motor de física preciso
+Comment[eu]=Kalitate altuko 3D grafikak eta fisika zehatzeko eragileak dituen motorrezko kirolen simulatzailea
+Comment[gl]=Simulador de deportes de motor con gráficos 3D de alta calidade e un motor de física preciso
+Comment[it]=Simulatore di guida con grafica 3d di alta qualità e un accurato motore fisico
+Comment[nl]=Motorsportsimulator met 3D-graphics van hoge kwaliteit en een nauwkeurige physics-engine
+Comment[pt]=Simulador de esportes a motor com gráficos 3D de alta qualidade e um motor de física preciso
+Comment[zh_CN]=具有高清3D画质和精准物理引擎的赛车模拟器
+GenericName=Racing Game
+GenericName[ca]=Joc de carreres
+GenericName[ca_ES@valencia]=Joc de carreres
+GenericName[de]=Rennspiel
+GenericName[es]=Juego de carreras
+GenericName[eu]=Lasterketen jokoa
+GenericName[gl]=Xogo de carreiras
+GenericName[it]=Gioco di corse
+GenericName[nl]=Race spelletje
+GenericName[pt]=jogo de corrida
+GenericName[zh_CN]=赛车游戏
+Keywords=race;racing;drive;driving;racer;driver;track;motorsport;game;
+Keywords[ca]=carrera;racing;conducció;deport de motor;joc;cotxe;simulació;
+Keywords[ca_ES@valencia]=carrera;racing;conducció;deport de motor;joc;cotxe;simulació;
+Keywords[de]=Rennen;Fahren;Motorsport;Videospiel;Auto;Simulation
+Keywords[es]=carrera;racing;conducción;deporte de motor;juego;coche;simulación;
+Keywords[eu]=Lasterketa;kondukzioa;motor-kirola;jokoa;kotxe/auto;simulazioa
+Keywords[gl]=carreira;racing;conducción;deporte de motor;xogo;coche;simulación;
+Keywords[it]=corse;racing;guida;guidare;motorsport,gioco,macchine;simulatore
+Keywords[nl]=racen, racing, autorijden, motorsport, spelletjes, auto's, simulatie;
+Keywords[pt]=corrida, racing, condução, esporte a motor, jogos, carros, simulação
+Keywords[zh_CN]=赛车;驾驶;赛车运动;游戏;汽车;模拟;模拟器;竞速;

View File

@ -42,12 +42,13 @@
#:use-module (gnu packages xml)
#:use-module (gnu packages xorg)
#:use-module (guix build-system cmake)
#:use-module (guix build-system trivial)
#:use-module (guix build-system gnu)
#:use-module (guix build utils)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix download)
#:use-module (guix gexp)
#:use-module (guix svn-download)
#:use-module (guix git-download)
#:use-module (guix packages)
#:use-module (guix utils))
@ -93,24 +94,32 @@ of the others")
(name "speed-dreams")
(version "2.3.0")
(source
(origin
(method svn-fetch)
(uri
(svn-reference
(url "https://svn.code.sf.net/p/speed-dreams/code")
(revision 8786)))
(sha256
(base32 "0bn0xj0ym50zc0fpbzadbxv77rw8ac0yaq0hr3dds35j095xj90b"))))
(origin
(method git-fetch)
(uri (git-reference
(url "https://forge.chalec.org/neox/speed-dreams")
(commit version)))
(file-name (git-file-name name version))
(sha256
(base32 "0w9l6lg4d20jiddkp1599l3hvy3y1745qv8pzb137kn8j2lz73c0"))))
(build-system cmake-build-system)
(arguments
(list
#:configure-flags
#~(list
"-DOPTION_UNLOAD_SSGGRAPH:BOOL=ON"
"-DCMAKE_CXX_FLAGS=-march=native"
"-DCMAKE_BUILD_TYPE=Release"
"-DOPTION_OFFICIAL_ONLY:BOOL=ON")
#:phases
#~(modify-phases %standard-phases
;(add-after 'unpack 'make-git-checkout-writable
;(lambda* (#:key inputs #:allow-other-keys)
;(make-file-writable "CMakeLists.txt")))
;(add-after 'unpack 'apply-patches
;(lambda* (#:key inputs #:allow-other-keys)
;(invoke "patch" "--force" "-p1"
;"speed-dreams-add-desktop-entry.patch")))
(delete 'validate-runpath)
(delete 'check))))
(native-inputs
@ -135,3 +144,5 @@ of the others")
(description
"SPEEEEEED.")
(home-page "https://www.speed-dreams.net/en/")))